it-swarm-ja.com

Intel wifi Support for AX200(Cyclone Peak)

PC: Razer Blade 15 "上級モデル(2019年半ば)

Wifiカード: Intel Wifi AX200 OS:Ubuntu 18.04.2

問題: Bluetoothが正常に機能していても、Wi-Fiを動作させることができません


カーネルはすでに更新されています + apt update && apt upgrade

[email protected]:~$ uname -sr
Linux 5.1.7-050107-generic

Wifiはまだ検出されないままです

[email protected]:~$ rfkill list
0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
6
lolo

その包み backport-iwlwifi-dkms PPAから canonical-hwe-team/pc-oem-dkms は、現在のHWEカーネルであるカーネルバージョン4.15と5.0の両方で機能します。ただし、カーネル4.15の実行中にパッケージをインストールする必要があります。カーネル5.0では、パッケージのインストール中にエラーが発生します。

パッケージが正常にインストールされたら、システムを再起動するだけで、wifiが機能します。

5
d4span

すでにカーネルを更新しているため、ここに別のオプションがあります。

linux-oem-osp1カーネルを試して、linux-firmwareを最新バージョンに更新できます。このカーネルは、19.04の5.0カーネルに基づく認定OEMマシン用で、AX200サポートがバックポートされています。パッケージが公式にサポートされているため、この方法をお勧めします。

$ Sudo apt install linux-oem-osp1 linux-firmware

または、18.04のデフォルトの4.15カーネルを使いたい場合は、Ubuntuアーカイブからbackport-iwlwifi-dkmsをインストールするだけです。

$ Sudo apt install backport-iwlwifi-dkms

backport-iwlwifi-dkmsパッケージは以前は canonical-hwe-team/pc-oem-dkms PPA に含まれていましたが、現在は標準のUbuntuアーカイブで利用できるため、PPAを追加する手間が省けます。

3
Anthony Wong

最新のLinuxカーネル> 5.1にアップグレードし、ワイヤレスアダプターに最新のファームウェアを使用するだけです。 https://www.intel.com/content/www/us/en/support/articles/000005511/network -and-io/wireless-networking.html

新しいオペレーティングシステムをインストールしてもかまわない場合は、最新のLinuxカーネルとファームウェアを備えたUbuntu 19.10日次ビルドから始めます。そのまま使用できます: http://cdimage.ubuntu.com/daily-live/current/

2
vahid-dan

この投稿を参照してください: https://unix.stackexchange.com/questions/518571/locating-drivers-for-intel-ax200-wireless-on-5-1-kernel

著者はIntelから返答を受け取りました。ドライバー自体はカーネルに組み込まれていないため、バックポートドライバーを使用するよう提案しました(これにより、私のラップトップでWi-Fiにアクセスできるようになりました[2019年中旬のRazer Blade])

https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi/core_release

2
Wei

カナダの説明

Intel AX200 instructions.png

Ubuntuに必要なカーネルをインストールできます。

新しいカーネルバージョンを取得するためにデスクトップ(16.04-> 18.04-> 19.04など)をアップグレードする必要はありません。デスクトップをアップグレードすると、操作が失われ(起動しなくなり)、急激な学習曲線が失われ、機能が失われる可能性があります(ただし、通常は新しい機能の向上によって相殺されます)。デスクトップをアップグレードするときは、バックアップを強くお勧めします。したがって、必要なのが新しいカーネルだけである場合は、慎重に計画する必要があります。カーネルだけをアップグレードする(そしてデスクトップを維持する)には、古いカーネルがまだそこから起動するため、バックアップは必要ありません。

1

私の場合、カーネル4.15.0-62(ubuntu 16.04)、Anthony Wongによるバックポートドライバーの状態を使用して、ドライバーを https://www.intel.com/content/www/usからインストールします。 /en/support/articles/000005511/network-and-io/wireless-networking.html 。 wifiは私に対応しています(1Mbpsではありません)。

0
Midas