it-swarm-ja.com

IPv6トラフィックをルーティングするようにOpenWRTを構成するにはどうすればよいですか?

最近、ルーターを購入し、kmod-ipv6とradvdがインストールされたOpenWRTをフラッシュしました。 IPv6接続を設定しようとしましたが、ルーターからのみipv6.google.comにpingを実行でき、ルーターの背後にあるコンピューターにはpingを実行できません。

私のルーターは「公式に」サポートされていません。つまり、トランクにパッチがないため、他の誰か(@ r31540)のコンパイル済みファームウェアを使用しています。しかし、radvd configureスクリプトは、私の場合には存在しない/lib/functions/network.shを使用しているため、正しく機能していません。そのため、/etc/config/radvdからradvd.confを生成できません。

/ 64サブネットはeth0では2001:da8:205:406a::/64です。

ルーターの背後にあるコンピューターにはIPv6アドレスがありますが、ネットワークにアクセスできません。

現在の構成ファイル:

radvd.conf

interface br-lan {
    AdvSendAdvert on;
    prefix 2001:da8:205:406a::/64 {
        AdvOnLink on;
        AdvAutonomous on;
        AdvRouterAddr on;
    };
};

/ etc/config/network

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option ifname 'eth1'
    option type 'bridge'
    option proto 'static'
    option dns '199.91.73.222 178.79.131.110'
    option ipaddr '10.224.0.1'
    option netmask '255.224.0.0'
    option ip6addr '2001:da8:205:406a::ff19:ff19/64'

config interface 'wan'
    option ifname 'eth0'
    option _orig_ifname 'eth0'
    option _orig_bridge 'false'
    option proto 'dhcp'
    option macaddr '40:6c:8f:3e:62:87'
    option accept_ra '1'
    option send_rs '0'

config switch
    option name 'eth1'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'eth1'
    option vlan '1'
    option ports '0 1 2 3 4'
    option vid '1'

config switch_vlan
    option device 'eth1'
    option vlan '2'
    option vid '29'

config route6

config route6が設定されていませんが、設定方法がわかりません。また、interface 'lan'の設定は正しいですか?

4
Mr.X

これをOpenWrtルーターから外しました。それはあなたを動かすはずです。

姿勢調整ビルドを使用する必要があります。これは以前のバージョンでは機能しません。

config route6
        option interface 'wan'
        option target '::/0'
        option gateway 'fe80::56e6:fcff:fef4:66f1'
        option metric '1'

ゲートウェイを実際のゲートウェイマシンのIPv6アドレスに変更します(リンクローカルアドレスまたはグローバルアドレスを使用できます)。もちろん、WANポートを介してルーターに直接接続する必要があります。アップストリームゲートウェイがルーターアドバタイズメントを送信している場合は、これ以上何もする必要はありません。


LANインターフェースは正常に見えます。ただし、完全を期すために、これが私のradvdセットアップです。

[email protected]:/etc/config# cat radvd

config interface
        option interface 'lan'
        option AdvSendAdvert '1'
        list client ''
        option ignore '0'
        option IgnoreIfMissing '1'
        option AdvSourceLLAddress '1'
        option AdvDefaultPreference 'medium'

config prefix
        option interface 'lan'
        option AdvOnLink '1'
        option AdvAutonomous '1'
        option ignore '0'
        list prefix '2001:db8:16:bf::/64'

config route
        option interface 'lan'
        list prefix ''
        option ignore '1'

config rdnss
        option interface 'lan'
        list addr '2001:4860:4860::8888'
        list addr '2001:4860:4860::8844'
        option ignore '0'

config dnssl
        option interface 'lan'
        list suffix ''
        option ignore '1'
1
Michael Hampton