it-swarm-ja.com

インストールした壊れたパッケージを見つけて削除するにはどうすればよいですか?

ここでいくつかの質問を参照して、壊れたパッケージを見つけて削除するための解決策を見つけました。比較的初心者なので、12.04 LTSマシンに11.10用に設計されたPPAをインストールしました。ターミナルでは、apt-get -f installを試してみてください この質問

11
stephenmyall

Synaptic Package Manager(Software Centerで利用可能)は、パッケージを管理するためのgraphicalツールであり、多くの機能の中で状態でパッケージをフィルタリングします。数回クリックするだけで、左側のパネルで目的のカテゴリを選択すると、修正が必要なパッケージのリストが表示されます。

6
Rafał Cieślak
  • ソフトウェアセンターから、またはターミナルで次のコマンドを実行して、Synaptic Package Managerをインストールします。

     Sudo apt-get install synaptic 
    
  • Unityダッシュにsynapticと入力してから、それを押して開きます Enter

  • 次に、次の手順を実行します。

    1. 「ステータス」カテゴリを選択します。これは、ステータス別に整理されたパッケージを表示します。
    2. 左上のペインから「壊れた依存関係」カテゴリを選択します。
    3. 壊れたパッケージを選択します。パッケージが複数ある場合は、すべてを選択して選択します Ctrl+A
    4. 次に、選択したパッケージを右クリックして、メニューで「完全削除のマーク」オプションを選択します。

    Screenshot showing "Mark for complete removal" on packages with broken dependencies

それでおしまい。壊れたパッケージはなくなりました。

28
Anwar

ダウンロードもGUIも不要:

壊れたパッケージをリストできます:

dpkg -l | grep ^..r 

rstate(3番目のフィールド)の意味:reinst-required(パッケージが壊れている、再インストールが必要)

dpkgフィールドの説明

これらのパッケージをリストおよび削除するには:

dpkg -l | grep ^..r | while read -r | tr -s ' ' | cut -d' ' -f2 | while read -r name; do Sudo apt-get remove "$name"; done

このスレッド からコピーされた回答)

3
JellicleCat

Ppaからインストールしたパッケージをクリーンアップするには、ppa-purgeを使用する必要があります(ppaはppa:xorg-edger/ppaであると仮定します)

  1. Sudo apt-get install ppa-purge
  2. Sudo apt-get update
  3. Sudo ppa-purge ppa:xorg-edger/ppa
  4. 疑わしい点がない場合は、削除またはダウングレードするパッケージのリストが表示され、Yと答えて待機します
  5. 運が良ければ、エラーで終了するはずです。そうでなければ、Sudo apt-get install -fを実行する必要があります。

手順5を実行してもエラーが発生する場合は、戻って質問を更新してください。

幸運を。

1
number5

壊れたパッケージを修正するためのスクリプトを作成しました。これは/var/log/dist-upgrade/apt.logで壊れたパッケージを検索し、パッケージ名を見つけて、指定されたコマンドをそれらに適用します。

このスクリプトの使用には注意してください。壊れたパッケージの中にはシステムに関連したものがあり、新しい問題を引き起こす場合があるためです。そのため、removeコマンドの代わりにinstallまたはupgradeコマンドを使用します。

ここから入手

以下のコマンドを使用してスクリプトをダウンロードします。

wget https://Gist.githubusercontent.com/EmpireWorld/8eb920165777399cfd684d8d4227a6e2/raw/17e6d4a151a6163aa45dd8302b965ed433b27741/fix-broken.sh

それを実行します:

./fix-broken.sh

また、次のように壊れたパッケージに適用するアクションを設定できます。

./fix-broken (install|upgrade|remove)

デフォルトのアクションはremoveです。

0
Hasan Bayat