it-swarm-ja.com

Alpine Linuxにnpmで最新のnodejsをインストールする最良の方法は何ですか

私はAlpine Linuxに基づいて独自のDockerコンテナーを構築しようとしており、そのコンテナーに複数のサービスを追加する必要があります(はい、これはベストプラクティスとしてはお勧めできませんが、現時点では組織の開発が少し遅れており、単一のdockerfileを要求しています私のカスタム画像)。

私は this の記事をチェックして、Alpine Linuxにnpmで最新バージョンのnodejsをインストールする方法を見つけました。ただし、apk add [email protected]またはこの説明で提供されているようなものはないようです。

また、Alpine Linuxには、リポジトリ here に最新バージョンのnodejs(v 8.X)がないようです。

それで、ソースからnodejsをインストールする必要はほとんどありますか?ただし、そのオプションは、Alpineリポジトリからインストールするだけの場合と比べて非常に遅くなります。

編集:

dockerfileにnodejs-currentを追加すると別の問題が発生する

ステップ...:apk update && apk add nodejs-current

---> e430b4d279e5での実行fetch http://dl-cdn.alpinelinux.org/Alpine/v3.4/main/x86_64/APKINDEX.tar.gz fetch http:/ /dl-cdn.alpinelinux.org/Alpine/v3.4/community/x86_64/APKINDEX.tar.gz fetch http://nl.alpinelinux.org/Alpine/Edge/testing/x86_64/ APKINDEX.tar.gz v3.4.6-213-gb6db4bd [ http://dl-cdn.alpinelinux.org/Alpine/v3.4/main] v3.4.6-160-g14ad2a3 [ http://dl-cdn.alpinelinux.org/Alpine/v3.4/community] v3.6.0-3765-g46dd4472f4 [ http://nl.alpinelinux.org/ Alpine/Edge/testing] OK:8679個の個別のパッケージが使用可能エラー:満たされない制約:nodejs-current(欠落):必要:world [nodejs-current]

7
Andy

2つのnodejsパッケージを提供します。

  • nodejs in main – LTSバージョン、
  • nodejs-current コミュニティ内–アップストリームによって呼び出された現在のバージョン。

したがって、最新バージョンが必要な場合は、次を実行してnodejs-currentをインストールします。

apk add nodejs-current

現在、v3.6の7.10.1(安定したブランチ)またはEdge(不安定な/ローリングブランチ)の8.5.0です。

@Nのような[email protected]サフィックスは使用していません。これは有効なパッケージ名ではありません。

16
Jakub Jirutka