it-swarm-ja.com

プラグインのインストールでFTP認証情報を要求する

私はFTPがインストールされていないサーバーにいて、FTPがインストールされません。今インストールしようとしているもの(WP-PageNavi)を含む、以前にプラグインをインストールすることができた別のWebサイトがあります。

誰もが彼らがこの問題に遭遇しないように彼ら自身が使うWordPressのための標準的な許可のリストを持っていますか?

私はこのトピックに関する WordPressの記事 を読み、このウェブサイトの他の質問を見ました。

任意の助けは大歓迎です。

2
Matt

ほとんどのWordPressインストールの標準アクセス権は、ディレクトリが755、ファイルが644です。

メディアのアップロード、自動プラグインのインストール、およびディレクトリの更新は、PHPが実行されているのと同じユーザーが所有する必要があります。通常、これは誰もいません:誰もいないかwww-data:www-data。

3
Chris_O

WebファイルがApache Webサーバーユーザー(Ubuntuでは "www-data")によって所有されていることを確認してください。次のようにしてこれを確認してください。

ls -al

そうでない場合は、次のように設定します。

chown -R www-data:www-data folder/
1
GavinR