it-swarm-ja.com

ローカルパッケージシステムを台無しにしたのですが、どうすれば修復できますか?

PPAを最近削除した後、ローカルパッケージシステムが台無しになりました。 Sudo apt-get -f installを実行して依存関係を修正するように求められます。

問題が解決するまで数日待っていたため(新しいpacakageのリリースにより依存関係が変更される場合があります)、結局は起こりませんでした。だから私の質問は次のとおりです。システムを再インストールすることが唯一の方法ですか?

Note:これはアルファリリースに関する問題を処理する場所ではないことは承知していますが、私の意見では、問題への対処方法について一般的な答えをする価値があります。

PS:特定の問題の端末出力

$ Sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
  libx264-118
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libglib2.0-0 libglib2.0-bin libglib2.0-dev
Suggested packages:
  libglib2.0-doc
The following packages will be upgraded:
  libglib2.0-0 libglib2.0-bin libglib2.0-dev
3 upgraded, 0 newly installed, 0 to remove and 150 not upgraded.
9 not fully installed or removed.
Need to get 0 B/3.062 kB of archives.
After this operation, 130 kB disk space will be freed.
Do you want to continue [Y/n]? y
dpkg: error processing libglib2.0-0 (--configure):
 libglib2.0-0:AMD64 2.31.14-0ubuntu1~build1 cannot be configured because libglib2.0-0:i386 is in a different version (2.31.14-0ubuntu1)
dpkg: dependency problems prevent configuration of libglib2.0-bin:
 libglib2.0-bin depends on libglib2.0-0 (= 2.31.14-0ubuntu1~build1); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing libglib2.0-bin (--configure):
 dependency problems - leaving unconfiguredNo apport report written because the error message indicates its a followup error from a previous failure.

dpkg: dependency problems prevent configuration of libglib2.0-dev:
 libglib2.0-dev depends on libglib2.0-0 (= 2.31.14-0ubuntu1~build1); however:
  Package libglib2.0-0 is not configured yet.
 libglib2.0-dev depends on libglib2.0-bin (= 2.31.14-0ubuntu1~build1); however:
  Package libglib2.0-bin is not configured yet.
dpkg: error processing libglib2.0-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: error processing libglib2.0-0:i386 (--configure):
 libglib2.0-0:i386 2.31.14-0ubuntu1 cannot be configured because libglib2.0-0:AMD64 is in a different version (2.31.14-0ubuntu1~build1)
dpkg: dependency problems prevent configuration of libgtk-3-0:
 libgtk-3-0 depends on libglib2.0-0 (>= 2.31.14); however:
  Package libglib2.0-0 is not configured yet.
dpkg: error processing libgtk-3-0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgail-3-0:
 libgail-3-0 depends on libglib2.0-0 (>= 2.31.14); however:
  Package libNo apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                                       No apport report written because MaxReports is reached already
                                              No apport report written because MaxReports is reached already
                                                                                                            No apport report written because MaxReports is reached already
                                   No apport report written because MaxReports is reached already
                                                                                                 No apport report written because MaxReports is reached already
                        glib2.0-0 is not configured yet.
 libgail-3-0 depends on libgtk-3-0 (= 3.3.12-0ubuntu1~build1); however:
  Package libgtk-3-0 is not configured yet.
dpkg: error processing libgail-3-0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gir1.2-gtk-3.0:
 gir1.2-gtk-3.0 depends on libgtk-3-0 (>= 3.3.12); however:
  Package libgtk-3-0 is not configured yet.
dpkg: error processing gir1.2-gtk-3.0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgtk-3-bin:
 libgtk-3-bin depends on libgtk-3-0 (>= 3.3.12-0ubuntu1~build1); however:
  Package libgtk-3-0 is not configured yet.
dpkg: error processing libgtk-3-bin (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgtk-3-dev:
 libgtk-3-dev depends on libgtk-3-0 (= 3.3.12-0ubuntu1~build1); however:
  Package libgtk-3-0 is not configured yet.
 libgtk-3-dev depends on gir1.2-gtk-3.0 (= 3.3.12-0ubuntu1~build1); however:
  Package gir1.2-gtk-3.0 is not configured yet.
 libgtk-3-dev depends on libglib2.0-dev (>= 2.31.14); however:
  Package libglib2.0-dev is not configured yet.
dpkg: error processing libgtk-3-dev (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libglib2.0-0
 libglib2.0-bin
 libglib2.0-dev
 libglib2.0-0:i386
 libgtk-3-0
 libgail-3-0
 gir1.2-gtk-3.0
 libgtk-3-bin
 libgtk-3-dev
E: Sub-process /usr/bin/dpkg returned an error code (1)
4
Ingo

これは私のために働いた:

  1. シナプスを開く
  2. There are broken packages on your system.と表示される場合は、Edit -> Mark broken packagesに移動して[適用]をクリックします。
  3. Synapticを閉じてSudo apt-get update && Sudo apt-get upgradeを実行すると、すべて正常に動作する可能性があります。
3
Ingo

Sudo dpkg --configure -aを実行してからSudo apt-get -f installを実行すると、トリックが実行されます

3
Chris Wayne

Sudo dpkg --configure --pendingは、完全にインストールされていないパッケージをクリーンアップする必要があります。インストールした後、または失敗した場合は、Sudo apt-get purge <packages>を試してください

0
Huckle