it-swarm-ja.com

RHEL7でgccをgcc-4.9にアップグレードします

redhat7にはgcc4.8.5があります。

4.9にアップグレードしてほしい。そのために私は以下のコマンドを使用しました

Sudo yum install devtoolset-3-gcc.x86_64

そして、私は以下の応答を得ました

Loaded plugins: Amazon-id, rhui-lb, search-disabled-repos
Resolving Dependencies
--> Running transaction check
---> Package devtoolset-3-gcc.x86_64 0:4.9.1-10.el6 will be installed
--> Processing Dependency: devtoolset-3-binutils >= 2.22.52.0.1 for package: devtoolset-3-gcc-4.9.1-10.el6.x86_64
--> Processing Dependency: devtoolset-3-runtime for package: devtoolset-3-gcc-4.9.1-10.el6.x86_64
--> Processing Dependency: libmpfr.so.1()(64bit) for package: devtoolset-3-gcc-4.9.1-10.el6.x86_64
--> Processing Dependency: libgmp.so.3()(64bit) for package: devtoolset-3-gcc-4.9.1-10.el6.x86_64
--> Running transaction check
---> Package devtoolset-3-binutils.x86_64 0:2.24-18.el6 will be installed
---> Package devtoolset-3-gcc.x86_64 0:4.9.1-10.el6 will be installed
--> Processing Dependency: libmpfr.so.1()(64bit) for package: devtoolset-3-gcc-4.9.1-10.el6.x86_64
--> Processing Dependency: libgmp.so.3()(64bit) for package: devtoolset-3-gcc-4.9.1-10.el6.x86_64
---> Package devtoolset-3-runtime.noarch 0:3.0-15.el6 will be installed
--> Processing Dependency: scl-utils >= 20120927-11 for package: devtoolset-3-runtime-3.0-15.el6.noarch
--> Running transaction check
---> Package devtoolset-3-gcc.x86_64 0:4.9.1-10.el6 will be installed
--> Processing Dependency: libmpfr.so.1()(64bit) for package: devtoolset-3-gcc-4.9.1-10.el6.x86_64
--> Processing Dependency: libgmp.so.3()(64bit) for package: devtoolset-3-gcc-4.9.1-10.el6.x86_64
---> Package scl-utils.x86_64 0:20130529-17.el7_1 will be installed
--> Finished Dependency Resolution
Error: Package: devtoolset-3-gcc-4.9.1-10.el6.x86_64 (slc6-scl)
           Requires: libmpfr.so.1()(64bit)
Error: Package: devtoolset-3-gcc-4.9.1-10.el6.x86_64 (slc6-scl)
           Requires: libgmp.so.3()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Mpfrがインストールされていることを確認しました

[[email protected] ~]$ Sudo yum install mpfr-devel
Loaded plugins: Amazon-id, rhui-lb, search-disabled-repos
Package mpfr-devel-3.1.1-4.el7.x86_64 already installed and latest version
Nothing to do
[[email protected] ~]$ Sudo yum install mpfr
Loaded plugins: Amazon-id, rhui-lb, search-disabled-repos
Package mpfr-3.1.1-4.el7.x86_64 already installed and latest version
Nothing to do

Gmpがインストールされていることも確認しました

[[email protected] ~]$ Sudo yum install gmp
Loaded plugins: Amazon-id, rhui-lb, search-disabled-repos
Package 1:gmp-6.0.0-12.el7_1.x86_64 already installed and latest version
Nothing to do
[[email protected] ~]$ Sudo yum install gmp-devel
Loaded plugins: Amazon-id, rhui-lb, search-disabled-repos
Package 1:gmp-devel-6.0.0-12.el7_1.x86_64 already installed and latest version
Nothing to do

しかし、それらは両方とも私のシステムにすでに存在しています。ここに何か足りないものはありますか? RHEL 7にgccバージョン4.9をインストールするにはどうすればよいですか?

2

2000年の「redhat7」ではなく、RHEL 7:Redhat Enterprise Linux 7

注:devtoolset-3はgcc/g ++のアップデートではなく、EL7で使用可能な追加のコンパイラーの1つにすぎません。つまり必要な数のバージョンのgccを同時にインストールできます。システムコンパイラがインストールされていることを確認してください:#yum install gcc-c++

必要なもの:libmpfr.so.1()(64ビット)

必要なもの:libgmp.so.3()(64bit)


「devtoolset-3」は古い(RHEL 6):1)これらのパッケージをインストールしてください(EL7用に構築、「2015年1月」).... compat-libgmp-4.3.1-1.sl7.x86_64.rpm, compat-libmpfr-2.4.1-1.sl7.x86_64.rpm

リンク、compat-libgmp https://drive.google.com/file/d/0B7S255p3kFXNZFJDdWtkV3RyZTA/view?usp=sharing ...およびcompat-libmpfr https:// drive。 google.com/file/d/0B7S255p3kFXNV0FoOVlPemRBS0k/view?usp=sharing

# cd Downloads/ && yum install compat-libgmp-4.3.1-1.sl7.x86_64.rpm compat-libmpfr-2.4.1-1.sl7.x86_64.rpm


2)完全なdevtoolset-3は必要ありません。これにより、gcc-4.9/g ++-4.9がインストールされます:# yum install devtoolset-3-gcc-c++ ...合計〜4パッケージ。 ... 'gfortran':# yum install devtoolset-3-gcc-gfortran

Gcc-4.9、g ++-4.9の有効化:$ scl enable devtoolset-3 bash...および$ gcc -vは「gccバージョン4.9」と表示されます(設定はターミナルを終了するまで有効です。)


5
Knud Larsen