it-swarm-ja.com

IPv6ホームセットアップOpenWrt 18.06.1 - どうやって?

私はIPv6ホームのセットアップに苦労しています。正直なところネットワーキングについてあまり理解していません。


私のISPは私に昨年と通知しました彼はIPv6に完全対応しています。

私はそれ以来私のルーターでそれを設定することができませんでした。私は彼らに言ったが、ほとんどすべてのウェブがデュアルスタック/ IPv4に対応しているので彼らはあまり気にしない。

それで、彼らは問題が彼らの側にあるかどうか確認するために一度だけ来ました:彼らはそうではないと私のオペレーティングシステム(Windows 10 Pro、Linux Mint 19.0 Cinnamon、Android 7.0)とその設定が問題であると主張します設定がひどいです。


問題

私が言及したすべてのシステムでIPv6を有効にすることを確信しているので、私のルーターは多分oldであることに気づくようになりました。モデルは TP-Link Archer C5 v1.2 ファームウェア日付 2015-04-28 です。

どういうわけか、時々、今日でも早く私は次のようにDHCPv6からセットアップを得ることができました:

IP: 2a02:768:7c00:14a:32b5:c2ff:feb9:c8f3/64
Gateway: fe80::225:90ff:fef5:7c13
DNS1: 2a02:768:0:1010::3
DNS2: 2a02:768:0:1010::2

質問(オリジナル)

上記のような設定でも技術的には正しいのでしょうか。ゲートウェイはおそらくローカルのみのアドレスと見なされますが、IPv6のみのサイトを閲覧できないという問題はありますか?

アップデート - OpenWrt


私は全くOpenWrtに不慣れです。案内してください。ありがとうございました。


私は自分のルータにOpenWrt 18.06.1をアップロードすることに成功し、またパブリックの静的IPv4アドレスでWifi 5Gと2.4Gの両方を機能させることができました。


基本情報

  • モデル:TP-Link Archer C5 v1
  • アーキテクチャ:クアルコムアテロスQCA9558 ver 1 rev 0
  • ファームウェアバージョン:OpenWrt 18.06.1 r7258-5eb055306f/LuCI openwrt-18.06ブランチ(git-18.228.31946-f64b152)
  • カーネルバージョン:4.9.120

私はrootとしてルータにSSH接続することができます。これが最も基本的な情報です。

# cat /etc/config/network

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd62:320d:015a::/48'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth1.1'
    option proto 'static'
    option ipaddr '192.168.0.1'
    option netmask '255.255.255.0'
    option ip6addr '2a02:768:7c00:14a:32b5:c2ff:feb9:c8f3/64'
    option ip6gw 'fe80::225:90ff:fef5:7c13'

config interface 'wan'
    option ifname 'eth0.2'
    option proto 'static'
    option ipaddr '10.7.113.62'
    option netmask '255.255.255.252'
    option gateway '10.7.113.61'
    option dns '8.8.8.8 10.255.255.10'

config interface 'wan6'
    option ifname 'eth0.2'
    option proto 'static'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '2 3 4 5 0t'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '1 6t'

# cat /etc/config/dhcp

config dnsmasq
    option domainneeded '1'
    option localise_queries '1'
    option rebind_protection '1'
    option rebind_localhost '1'
    option local '/lan/'
    option domain 'lan'
    option expandhosts '1'
    option authoritative '1'
    option readethers '1'
    option leasefile '/tmp/dhcp.leases'
    option resolvfile '/tmp/resolv.conf.auto'
    option nonwildcard '1'
    option localservice '1'

config dhcp 'lan'
    option interface 'lan'
    option start '100'
    option limit '150'
    option dhcpv6 'server'
    option ra 'server'
    option force '1'
    option ra_management '1'
    option leasetime '15m'
    option ra_default '1'

config dhcp 'wan'
    option interface 'wan'
    option ignore '1'
    option ra 'server'
    option dhcpv6 'server'
    option ra_management '1'
    list dns '2a02:768:0:1010:0:0:0:3'
    list dns '2a02:768:0:1010:0:0:0:2'

config odhcpd 'odhcpd'
    option maindhcp '0'
    option leasefile '/tmp/hosts/odhcpd'
    option leasetrigger '/usr/sbin/odhcpd-update'
    option loglevel '4'

コメントに答えるには:

ipv6.google.comにpingできますか。 IPアドレスは論理的に見えます。それはまたあなたのISPの設定が何であるかを言及する価値があります - 私はその日のうちに彼らのフォーラムで私のものを見つけなければなりませんでした、そして設定はあなたがケーブルか光ファイバーかに依存します。現地の知識があると役に立つ場合があります。

  • ping6にできません。 100%のパケット損失.

  • ISP設定 - 下記を参照してください。

  • 私は通常のケーブル=イーサネット=約20/10 Mbit/sにいます。

  • 何でも聞いてください。


GUIからの現在のステータス:

Current statuss from GUI

私は成功せずにDHCPv6を使おうとしました。私がこの質問を投稿したのはそのためです。


ISP


DHCPv6

私はISPから知らされました、彼らはDHCPv6を通して自動的に接頭辞を割り当てます、そしてこの時点で静的な設定は不可能であること。

だから、私はすべての静的設定を削除し、64プレフィックスの強制要求でDHCPv6をオンにしました。

WAN6セクションでDHCPv6を有効にするためにapplyを押す前は、次のようになっていました。

network.wan6.proto=dhcpv6
network.wan6.reqaddress=force
network.wan6.reqprefix=64

これは変更されていません。さらに、IPv6アップリンクは未構成としてグレーアウトされています。

彼らの技術者が私の代わりに問題を解決するという保証なしに彼らは莫大な量のお金を欲しているという事実に照らして、私はこの質問に1つのジューシーな恩恵を置いています。

あなたが私に新しい質問をするときはいつでもそれがより明確になるように、私はこの質問を編集しようとします。


私は毎日3日間OpenWrtインターフェースをブラウズしていますが、多分私は(少なくとも私にとっては)新しいものを見つけました、それはVLANと呼ばれています、そして私はその目的が何であるかわかりません。

VLAN settings


ISPスターネット

私は彼らが彼らのウェブサイト上にいくつかの本当に貴重な情報を持っていないのを見つけました:

http://www.starnet.cz/info/ipv6

これは、たとえばGoogleで簡単に翻訳できます。

別のことが確認された、私は彼らの Facebookページ で見つけました:

接頭辞は64です。そして、彼らは56も作るつもりです。


Ping6

現在の設定で、そしてLuCI(GUI)インターフェースから直接、私がping6ipv6.google.comを試みるとき、私は得ます:

PING ipv6.google.com (2a00:1450:400d:805::200e): 56 data bytes
ping6: sendto: Permission denied

バグ?

私は私の正確なバージョンの以下のバグ報告を見つけました:

https://bugs.openwrt.org/index.php?do=details&task_id=1763

その人は17.0.1.5にダウングレードすることでIPv6の問題を解決することを提案していますが、誰でもそのバグレポートを見てもらえますか、私は本当にわかりません。


バグ確認済み

バグレポートは絶対に正しいです、なぜそれが割り当てられないのか、なぜそれが非常に低い優先度を持つのかわかりません、しかし私は17.xファームウェアでIPv6アドレスプレフィックスを取得することができました:

IPv6 is on in 17.x firmware


ハッチ

私は17.xファームウェアからのインターネット接続を持っていません、ただルーターから直接pingとping6を行うことができる、これを理解するのを助けてください。


IPv6 Upstreamがついに登場!

IPv6 Upstream is finally on

17.xにダウングレードした後、クライアントから利用可能なインターネット接続がありませんでした、しかし18.xファームウェアに戻ってアップグレードされるとき、IPv6アップストリームはついにオンになります。


LAN IPv6

最後のステップは、クライアントに対してIPv6を有効にすることです。私はWindows/Linux/AndroidにIPv6を持っていないので、何か問題があります、私はそれが何であるかわかりません。


バウンティはまだオンです

私はルールを尊重しているので、ボーナスのキャンセルリクエストはもうありません。

提供された300ポイントを誰かに授与するために、私はあなたのためにいくつかのボーナス質問をします。


300ポイントのボーナス質問

  1. Stateful Stateless IPv6の割り当ての違いと有用性について誰かが説明できますか?セキュリティへの影響などよく引用してください、ありがとう。

  2. DUID = DHCP Unique IDentifierとは何ですか。その目的と使用方法は何ですか。セキュリティへの影響などよく引用してください、ありがとう。

9

そのため、2つの別々の問題がありました。

  • WAN - IPv6アップストリームが接続していない

  • LAN - 設定にエラーがあります


#1、つまりWANの設定では、GUIが提供するほとんどすべてのことを試しても成功しませんでした。

私はようやく回避策を思いついたので、私はあなたとそれを共有します。

  1. 17.xファームウェアにダウングレードします。それはあなたの設定を保持します、心配しないでください。

  2. 18.xファームウェアにアップグレードします。

これですべてです、魔法のようにIPv6 WAN Upstreamがついに接続しています。


#2、つまりLAN構成の場合は、次のように設定します。

  1. ネットワーク - インターフェース - LAN - 共通設定 - 一般設定タブ - IPv6割り当て長はあなたのプレフィックスの長さに設定しなければなりません。

  2. ネットワーク - インターフェース - LAN - DHCPサーバーはあなたのトポロジーがどのようになっているかに基づいています。

    • ルータアドバタイズメントサービス:サーバモード

    • DHCPv6サービス:サーバモード

    • NDPプロキシ:ハイブリッドモード

    • DHCPv6-Mode:ステートレス+ステートフル

構成にさらにエラーがある場合は、この回答を更新していきます。


私は今私のWindows 10、Linux Mint 19、そしてAndroid 7.0を http://test-ipv6.com/ でテストしました

そして私は得た:

IPv4 DNSレコードでテストする
ok (0.267s) using ipv4
IPv6 DNSレコードでテストする
ok (0.168s) using ipv6
デュアルスタックDNSレコードを使ったテスト
ok (0.206s) using ipv6
デュアルスタックDNSとラージパケットのテスト
ok (0.154s) using ipv6
DNSなしでIPv4をテストする
ok (0.108s) using ipv4
DNSなしでIPv6をテストする
ok (0.091s) using ipv6
IPv6ラージパケットをテストする
ok (0.256s) using ipv6
ISPのDNSサーバーがIPv6を使用しているかどうかをテストします
ok (0.275s) using ipv6
IPv4サービスプロバイダを探す
ok (0.128s) using ipv4 ASN 44489
IPv6サービスプロバイダを探す
ok (0.107s) using ipv6 ASN 44489

これは100%OKです。これら2つのスキップされたテストはHTTPSを使用してテストサイトにアクセスすることによって引き起こされています。これはまだベータ版ですので、プレーンHTTPを使用することをお勧めします。 http://test-ipv6.com/

それでおしまい。私は今ファイアウォールとステートフル+ステートレスIPv6をいじる必要があります、しかしそれは私がIPv6を私の家で動作させることに成功したという事実を変えないでしょう。


私はもう1つテストサイトを見つけました。

IPv6のみ: http://v6.testmyipv6.com/

デュアルスタック: http://ds.testmyipv6.com/

2

手短に:

IPv6のステートフルDHCPv6自動設定は、IPv4のDHCPと同等です。 DHCPv6サービスは、IPv6アドレスをクライアント装置に提供し、クライアントとサーバの両方がそのアドレスの「状態」(すなわちリース時間など)を維持する。ルーター広告メッセージ内のルーターは、新しく出現したホストに、DHCPv6サーバーからすべてのアドレス(グローバルアドレス、DNSアドレス、SIPプロキシサーバーアドレス)を要求するように指示します。

ステートレスDHCPv6は、クライアントデバイスによるIPv6アドレスの自動設定およびルータアドバタイズメントに基づくルーティング用です。ルーターは、DNS、SIPプロキシサーバーアドレスなどの追加情報のみをDHCPv6サーバーから取得するように、新しく出現したホストに指示します。グローバルアドレスは、ルーターアドバタイズメントにあるプレフィックスによってホストに与えられます。メッセージ。ルータは64ビットのプレフィックスを与え、ホストは EUI-64 方式で変換されたMACアドレス(48ビット)を使用してグローバルIPv6アドレスを取得します。

詳しくは、記事 から、ステートフルIPv6とステートレスIPv6の違いは何ですか?

IPv6アドレス割り当てオプション

  • 静的(手動)アドレス割り当て - IPv4とまったく同じです。

  • ステートレスアドレス自動設定(SLAAC) - ノードはローカルリンク上でルーターによって定期的に送信されるICMPv6ルーターアドバタイズメント(RA)メッセージをリッスンするか、RA要請メッセージを使用してノードから要求されます。 。それから、それらはそのインターフェースEUI-64(イーサネットインターフェース上のMACアドレスに基づく)とルーター広告を介して得られたリンクプレフィックスを組み合わせることによってグローバルユニキャストIPv6アドレスを作成することができます。これは単純な「プラグアンドプレイ」ネットワーキングを提供するIPv6だけに特有の機能です。デフォルトでは、SLAACはIPv6アドレスとデフォルトゲートウェイ以外のものをクライアントに提供しません。 SLAACはRFC 4862で大いに議論されています。

  • ステートレスDHCPv6 - このオプションを指定した場合でもSLAACはIPアドレスを取得するために使用されますが、DHCPは「その他」の設定オプションを取得するために使用されます。ここでの利点は、DHCPサーバーが個々のクライアントに関する動的状態情報を格納する必要がないことです。膨大な数のエンドポイントが接続されている大規模ネットワークの場合、ステートレスDHCPv6を実装すると、アドレス状態の更新に必要なDHCPv6メッセージの数が大幅に減少します。

  • ステートフルDHCPv6 - ホストがDHCPサーバーからIPv6アドレスと追加パラメータの両方を受信するIPv4 DHCPとまったく同じように機能します。 IPv4のDHCPと同様に、DHCPv6インフラストラクチャのコンポーネントは、設定を要求するDHCPv6クライアント、設定を提供するDHCPv6サーバー、およびクライアントがDHCPv6サーバーを持たないサブネット上にあるときにクライアントとサーバー間でメッセージを伝達するDHCPv6リレーエージェントで構成されます。 RFC 3315で、DHCP for IPv6の詳細を学ぶことができます。

注:IPv6でデフォルトゲートウェイを取得する唯一の方法は、RAメッセージを使用することです。現時点では、DHCPv6はデフォルトルート情報を伝送しません。

DHCP固有識別子

これはクライアント自身によって生成された一意の識別子で、DHCPv6サーバで一意に識別されます。

から ウィキペディアDHCPv6

DHCP固有識別子

DHCP Unique Identifier(DUID)は、DHCPv6サーバからIPアドレスを取得するためにクライアントによって使用されます。 2バイトのDUIDタイプフィールドと、最大128バイトの可変長識別子フィールドがあります。実際の長さはその種類によって異なります。サーバーはDUIDをそのデータベースと比較し、構成データ(アドレス、リース時間、DNSサーバーなど)をクライアントに配信します。 DUIDの最初の16ビットにはDUIDタイプが含まれており、そのうち4つのタイプがあります。残りのDUIDの意味は種類によって異なります。

4
harrymc