it-swarm-ja.com

zypperに特定のバージョンをインストールさせる

古いバージョンのrpmが含まれている自分の個人リポジトリがあります。ブーストライセンスバージョン1.36.0.11.17をインストールする場合、次のようにします

zypper install boost-license=1.36.0-11.17

これは壊れているようですが、リビジョンを存在しないことがわかっているものに変更すると、エラーが発生する代わりに最新のリビジョンがインストールされてしまうので、愚かです。

Zypperに特定のrpmを強制的にインストールさせる唯一の方法は、rpmの正確なURL httlp // mylocalrepository/myrpms/boost-1.36.0.11.17.src.rpmを指定することです。

特定のバージョンをインストールするように設計されているzypperを使用する方法や、存在しない場合のエラーについて教えてください。

6
Fearghal
zypper in -f <package-with-version>

正確なバージョンを知りたい場合は、次のようにして見つけることができます。

zypper se <package>
5
Hoorhay