it-swarm-ja.com

Ubuntu Server 14.04 Apache 2.4 TLSv1.2 / TLSv1.1サポート

最近、ゼロからの新規インストールにより、サーバーをUbuntu Server 12.04からUbuntu Server 14.04にアップグレードしました。

問題が1つだけ残っています。 12.04では、mod_sslを使用したApache 2.2はTLSバージョン1、1.1、および1.2をサポートしていました。 14.04およびApache 2.4にアップグレードした後、ApacheはTLSバージョン1のみをサポートし、1.1および1.2のサポートが欠落しています。

2.2-> 2.4(mod_ssl設定の変更なし)の移行ガイドと、SSLProtocol構成オプションに関するmod_sslのドキュメントの両方に従いました。

両方

SSLProtocol TLSv1.2 TLSv1.1 TLSv1

そして

SSLProtocol TLSv1.2

動作しない。 Apacheに新しいTLSバージョンもサポートするよう説得する方法はありますか?

問題は私の側からの変更なしで解決されたようです。どうやらlibsslは、TLSv1.1/TLSv1.2サポートなしで最初にコンパイルされたようです。

3
Jan Henke

構成を変更することなく、問題は修正されました。どうやら14.04のlibsslは、TLSv1.1/TLSv1.2のサポートなしで最初にコンパイルされたようですが、現在では修正されています。

1
Jan Henke