it-swarm-ja.com

ファンシーボックスエッセイワードプレスプラグインは多言語サイトで動作しません

多言語のサイトがあります。私はfancyboxを使ってYouTube映画を見せたい(または他の同等の解決策)

プラグインがインストールされ設定されます。彼のバージョンをチェックすると - すべてうまくいきました。反対側のEnでは、YouTubeにリダイレクトされます。

JA: http://www.mtbsuisse.com/en/category/videos/ HE: http:/ /www.mtbsuisse.com/category/videos/

これが起こる理由は何ですか?

多言語サポートにqtranslateを使用しています

*今のところサイトのデフォルトをHEに変更

1
hannit cohen

別の解決策を得ました。 wp-fancybox-easywp-lightpop に置き換えてください。 Wp-lightpopは箱から出して素晴らしく機能します。 1.設定ページに移動し、ポップアップとして表示されるリンクを変更します(そうでない場合はオーバーレイとして言語ナビゲーションリンクが開きます)2.ボックススタイルを変更します(ルックアンドフィール)

問題が解決しました :-)

1
hannit cohen

あなたは最も確実にあなたが複数の言語のために使うアドオンと Easy Fancy-box(wordpress Plugin) の間に「非互換性」を経験します。

Wordpressは複数の言語をネイティブにサポートしていないため、利用可能なプラグインのほとんどはそれをサポートしていません。多言語の詳細については、 を参照してください。多言語サイトを実装するためのオプションは何ですか?

あなたの問題に対する解決策を見つけるためには、プラグインがあなたの多言語機能をどのようにサポートできるかを調べる必要があります。ブログに複数の言語を追加した方法を書いたことがないため、質問でこれに回答することはできません。プラグインによって行われる場合は、通常、その情報をプラグインのホームページまたはフォーラム、あるいは他のユーザーが提供する wordpress support forums にあります。

更新:

qtranslate(Wordpress Plugin) を使用していることを追加したので、次の操作を実行できます。これが自分の設定の問題ではないことを確認してください。側。そうでない場合は、fancyboxプラグインの作者に連絡して、qtranslateを使用して多言語サイトとの互換性を提供してもらいたいと考えていることを伝えてください。 qtranslateは非常に人気があるので、一部のプラグイン作者はそれをサポートしても構わないと思っています。

2
hakre