it-swarm-ja.com

libfaac-devのインストール方法は?

/etc/apt/source.listを編集してrestrictedおよびpartnerリポジトリを作成しましたが、結果は常に次のようになります。

Sudo apt-get install libfaac-dev ....
....
E: Unable to locate package libfaac-dev

パッケージはオーディオコーデックで使用され、ffmpegが使用します。

10
Andrew_1510

libfaac-devはマルチバースリポジトリにあります。したがって、マルチバースリポジトリも含めるように/etc/apt/sources.listを編集する必要があります。 deb http://archive.ubuntu.com/ubuntu natty main restricted universe multiverse

変更後、次のコマンドを実行してlibfaac-devをインストールします。

Sudo apt-get update && Sudo apt-get install libfaac-dev
15
jokerdino

この問題は私を殺しましたが、私はそれを理解しました。 /etc/apt/sources.listに次の行を追加する必要があることがわかりました

deb http://us.archive.ubuntu.com/ubuntu/ precision-updates multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ precision-updates multiverse

つまり、マルチバースの場合、合計で4行になるはずです。

deb http://us.archive.ubuntu.com/ubuntu/ 正確なマルチバース
deb-src http://us.archive.ubuntu.com/ubuntu/ 正確なマルチバース
deb http://us.archive.ubuntu.com/ubuntu/ precision-updates multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ precision-updates multiverse

8
neanderslob

コンパイルしてみてください

$ wget -O fdk-aac.tar.gz https://github.com/mstorsjo/fdk-aac/tarball/master
$ tar xzvf fdk-aac.tar.gz
$ cd mstorsjo-fdk-aac*
$ autoreconf -fiv
$ ./configure --prefix="$HOME" --disable-shared
$ make
$ make install
0
Dang_Ho