it-swarm-ja.com

UbuntuにSQLite PDO拡張機能をインストールする方法

デフォルトのUbuntu PHPパッケージにはPDO SQLite拡張機能が含まれていません。SQLitePDO拡張機能をインストールするにはどうすればよいですか?apt-get経由で簡単にインストールできるパッケージはありますか?

20
wowpatrick

ただ:

Sudo apt-get install php5-sqlite

次回は、次の方法で検索できます。

apt-cache search php | grep sqlite
30
Michał Šrajer

Ubuntu 16.04にはphp5-sqliteはありません。必要なもの:

Sudo apt-get install php7.0-sqlite
Sudo service Apache2 restart

php5-sqlite-php5のSQLiteモジュールphp-mdb2-driver-sqlite-PHP PEAR MDB2にSQLiteドライバーを提供するモジュール

4
sac

明確にするために、私は最近この問題に入りました、php7.2のために実行する必要がありました

Sudo apt-get install php-sqlite3

これはsqlite-3をインストールしましたが、php-sqliteという名前のパッケージはありませんでした

3
Shobi

まず、phpのバージョンを確認します。

php -v

次に、拡張機能をインストールします。

Sudo apt-get install php[version-here]-sqlite3

たとえば、PHP 7.2の場合:

Sudo apt-get install php7.2-sqlite3

Apacheサーバーを再起動します。

Sudo service Apache2 restart

モジュールを一覧表示すると、sqliteが出力されます。

php -m | grep sqlite
1