it-swarm-ja.com

VirtualBoxにインストールしたときにUbuntu 18.04 LTSが起動時にハングするのはなぜですか?

デフォルトの仮想マシン設定を使用して、VirtualBoxにUbuntu 18.04 LTSをインストールしました。しかし、Ubuntu 18.04 LTSは起動画面でハングアップし、ログイン画面に到達しません。これはなぜなのか、そしてどうすれば修正できるのでしょうか。

12
juhist

Virtualboxでvmをシャットダウンし、Ubuntu仮想マシンの設定を編集してからDisplayに移動します。 [ビデオメモリ]スライダを一番右まで動かします。次に、Acceleration:Enable 3D Accelerationをオンにします。

もう一度vmを起動します。これはVirtualbox V5.2.12にあります

8
warhansen

問題は、Ubuntu 18.04 LTSがVirtualBoxのデフォルトの1GB RAM設定を好まないことです。 Ubuntu 18.04 LTSは1GBのRAMで動作すると宣伝されていますが、私の場合は動作しませんでした。

仮想マシンをシャットダウンしてメモリを増やします。理想的には少なくとも2GBです。 Ubuntu 18.04 LTSを再インストールする必要はありません。実際には、デフォルトの1GB RAMのみでインストールするのが理想的です。RAMサイズが大きくなるとスワップファイルのサイズも大きくなるためです。ホストとゲスト).

メモリを増やして仮想マシンを再起動した後、起動画面でハングアップしなくなりました。

メモリサイズが調整されると同時に、仮想マシンにより多くのCPUを割り当てることは意味があります。デフォルトのCPU数は1ですが、今日のほとんどのローエンドのラップトップCPUにも少なくとも4つの仮想CPUコアがあり、優れたものには8つあります。

3
juhist

私の場合は、他の答えの解決策はすべてすでに適用されていますが、それでも問題はありません。問題は、レガシに設定されたVMの準仮想化設定であり、デフォルトに変更すると問題が解決したことが判明しました。

1
user301924

私は上記のヒントをすべて試してみましたが、どれもうまくいきませんでした。さらに3時間後、私は前回のDockerインストールで私の(Win10)マシン上でHyper-Vが有効になったことに気付きました。そのため、別のヒントとして、Hyper-Vまたは他のハイパーバイザーがまだ実行されていないことを再確認し、実行されている場合は無効にします。頑張ってトラブルシューティング。

1
Jirka Horník

Windows 10 PCのVirtualBox 6.0.10でUbuntu 18.04を実行しています。 Ubuntuを起動してもログインプロンプトが表示されなくなり、画面が空白になりました。ビデオメモリを16 kbから64 kbに増やしたところ、すべて正常に動作するようになりました。

0
nanomanpa

Jirkaの答えが私に問題解決の手助けとなる手がかりを与えてくれました。 Windows 10 Hyper Vシステムを無効にする必要がありました。これらの指示は私を助けました:

https://ittutorials.net/Microsoft/hyper-v/how-to-disable-the-hyper-v-feature-in-windows-10/

Hyper Vを無効にしてからマシンを再起動する必要がありました。

これによりVirtualBoxはUbuntu 18.03を正常に起動するように起動し、起動時にハングしませんでした。これと同じ問題がUbuntu 16.04でも発生しました。

0
mikey-no

MacOS上でUbuntu 18.04でVMを実行しています。ゲストは十分なベースメモリ(RAM)と複数のプロセッサを持っています。

(これは、別の場所にあるPC上のハードウェア経由で直接使用した未加工のVMです。通常、OSのアップデートがある場合は、それを処理します。ゲストの以前のアップデートには何かがインストールされています。それはmacOS + rawVMコンボのセットアップを台無しにしました。)

私のマシンは、ある日それが正常に起動しなくなるまで、macOS VM上でうまく動いていました。ログイン画面の直前にはまってしまい、Ubuntuが紫色の背景に書かれています。

これは私がそれを修正するためにしたことです:

  1. VB applicationとHostを再起動します。問題は解決しませんでした。

  2. VirtualBoxを6から6.08に更新します。問題は解決しませんでした。

  3. 他の記事で示唆されているように3Dアクセラレーションを無効にします。問題は解決しませんでした。だから私はそれを再び有効にしました。私のビデオメモリはすでに128 MBなので変更しませんでした。

  4. グラフィックコントローラをVMSVGAからVBoxSVGAに変更しました。これで問題は解決しました。それは今また正しく機能しています(そして私の3Dアクセラレーションはまだ有効です)。

0
Daniel