it-swarm-ja.com

WSLでapt-get installが機能しない

Windows 10 Ubuntu bashがパッケージのインストールに失敗する。以下のコマンドで新しいパッケージをインストールしようとすると、同じエラーが発生します。

[email protected]:/mnt/c/Users/vadap# apt-get install atom
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package atom

これはatom pacakgeだけではありませんが、pipなどの他のパッケージもインストールしようとしましたが、同じエラーが発生しました。

7
Devoloper250

以下の2つのコマンドを実行すると、パッケージをインストールすることができました。

Sudo apt update

Sudo apt install python3-pip

ソース- https://linuxize.com/post/how-to-install-pip-on-ubuntu-18.04/

13
Devoloper250

システム:Windows 10 Enterprise、Ubuntu Windows Subsystem for Linux。

私はこのコマンドを実行しました:

Sudo apt-get install dos2unix

私はこのエラーがありました:

E: Unable to locate package dos2unix

次に実行しました:

Sudo apt-get update

その後:

Sudo apt-get install dos2unix

正しくインストールされました。

2
ProtoHumanCam

同じエラー、後で解決:

Sudo vi /etc/apt/sources.list # add source
Sudo apt update # update source cache

私のsources.listファイル:

deb http://mirrors.163.com/ubuntu/ bionic main restricted
deb http://mirrors.163.com/ubuntu/ bionic-updates main restricted
deb http://mirrors.163.com/ubuntu/ bionic universe
deb http://mirrors.163.com/ubuntu/ bionic-updates universe
deb http://mirrors.163.com/ubuntu/ bionic multiverse
deb http://mirrors.163.com/ubuntu/ bionic-updates multiverse
deb http://mirrors.163.com/ubuntu/ bionic-backports main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted
deb http://security.ubuntu.com/ubuntu/ bionic-security universe
deb http://security.ubuntu.com/ubuntu/ bionic-security multiverse

一部のソースはグローバルに適用されない可能性があるため、場所に応じてこのリストを編集してください。

0
Qinsi

「atom」はデフォルトのパッケージの一部ではないため、エラーが発生しますが、WSLはAtom)のようなグラフィカルアプリケーションをサポートしないため、とにかく機能しません。

彼らのウェブサイト atom.io から入手できるWindowsにインストールすることをお勧めします。

パッケージが実際にパッケージシステム内にあることを確認するには、apt search <whatever>を使用するか、より単純な出力apt-cache search <whatever>を使用できます。

注:次のことは行わないでください。ただし、完全を期すために、実際にインストールする方法を追加します。

次のコマンドでatomリポジトリを追加する必要があります:Sudo add-apt-repository ppa:webupd8team/atom

その後、最初にapt-get updateで検索キャッシュを更新し、次にapt-get install atomでパッケージをインストールすることで、インストールできます。

0
Mikael Kjær