it-swarm-ja.com

Joomla 1.7 Extension Manager:アップデートにアップデートが表示されない

JoomlaインストールをJoomla 1.6から可能な最新のJoomlaバージョンに更新しようとしています。少なくともバージョン2.5、できれば3.Xにしようとしています。

このサイト の指示に従って、バージョン1.7.0に正常に更新しました。これはいい。問題は、サイトがExtension Managerの自動更新を使用してバージョン2.5に更新するように指示していることです。しかし、これは私が見ているものです:

enter image description here

誰もが利用可能なアップデートがあることを知っているので、なぜ利用可能なアップデートが表示されないのか誰か知っていますか?

更新を行うためのより良い方法についての提案はありますか?どうもありがとう!

6

私は1.7.xから2.5に正常に移行できなかったので、これは実際には回答ではありませんが、他の人にとって有用な情報であるか、回答につながる可能性があります。

私の知る限り、1.xのワンクリック更新のメタデータは Joomla更新サイト から削除されているため、利用可能な更新はありません。更新サイトのメンテナーは、このプロセスをナビゲートするときに、恥ずかしさの塩辛い涙を感じるようにタイムリーにサイトを更新していない人のように。アップグレードに関する既存のチュートリアルのほとんどは、ワンクリックアップグレードの方法を指摘しているだけなので、これは物事をかなりトリッキーにします。しかし、手動で更新するために このガイド を見つけました。

何がうまくいったか

最新の1.7バージョン(1.7.5)へのアップグレード:

  1. データベースとファイルの完全バックアップを取ります。

  2. 1.7.0-> 1.7.5安定パッチリリースを こちら からダウンロードします。

  3. パッチアップデートをJoomlaルートに直接解凍します。

  4. データベースの更新を手動で実行します。このCLI忍者アクションは私に役立ちました:

    $ ls -al administrator/components/com_admin/sql/updates/mysql/1.7.*
    ...shows list of update sql files
    
    ...now step through each file sequentially from the version after your original version:
    $ cat administrator/components/com_admin/sql/updates/mysql/1.7.1-2011-09-15.sql.sql  | sed s/#_/my_table_prefix/g | mysql -uroot -p my_dbname
    

    当然、独自のテーブルプレフィックスとデータベース名を代入し、毎回DBパスワードを入力する必要があります。

  5. 管理者としてサイトにログインし、すべてが機能していることを確認できます。そうでない場合は、バックアップを復元して、最初からやり直す必要があります。

うまくいかなかったもの

これを行った後、同様の手順に従って、2.5.28 Stable Updateリリースをダウンロードして解凍し、ガイドで提案されているように「存在しない」ファイルを削除します(指定したパスで終了することに注意してくださいscript.phpないscripts.php)、および残りのデータベース更新を実行します。

残念ながら、その後、いくつかのエラーメッセージが表示され、かなり機能しないサイトができました。

Call to undefined method JHtml::getJSObject() in /var/www/.../libraries/cms/html/behavior.php on line 299
Call to undefined method JAdministrator::setHeader() in /var/www/.../libraries/cms/html/behavior.php on line 765

この時点で、損失を減らし、1.7.5に戻しました。誰かがこの点を乗り越えることができるなら、この答えに遠慮なく追加してください。

1
contrebis

提供したスクリーンショットは、Joomla自体ではなく、拡張機能のアップデートを示しています。まず、[キャッシュの消去]ボタンをクリックしてから、トップメニューでComponents >> Joomla!Updateに移動します。

これにより、更新が表示されます。そうでない場合は、[オプション]に移動して、長期リリースの更新を検索していることを確認してください。

お役に立てれば

1
Lodder

まずバックアップを作成してから、これを試してください。

  1. この指示に従ってJoomla 1.6.xをJoomla 2.5.xにアップグレードします

http://www.ostraining.com/blog/joomla/upgrade-joomla-16-to-25/

または

http://docs.joomla.org/J2.5:Upgrading_from_an_existing_version

  1. すべてのコンポーネント、プラグイン、テンプレートがJoomla 3.3の準備ができていることを確認してください
  2. Remembermeプラグインを非アクティブ化します。
  3. 次にJoomlaに行きます! [コンポーネント]メニューで更新し、[オプション]ボタンをクリックします
  4. 更新サーバーの設定を短期サポートに変更して保存します
  5. 次に、最新のJoomlaアップデートが表示され、通常の方法で処理できます。
  6. Remembermeプラグインをアクティブ化します。
1
Joomla Agency