it-swarm-ja.com

pacman / yaourtによる選択的な更新?

ArchLinuxでyaourtを使用しています。

  • yaourt -Syuを実行することは可能ですが、コア/エクストラからのパッケージまたは私が欲しいものだけを含めますか?
  • 単一のパッケージを更新する方法は? yaourt -U <package>が機能しません(パッケージが見つからないか、読み取れませんでした)。 yaourt -S <package>を使用する必要がありますか?

編集

  • yaourt -S <package>の使用に問題があります:利用可能な更新がない場合、パッケージはとにかく再インストールされます
8
user905686

最初のポイント:

ヨーグルト-Syuを実行することは可能ですが、コア/エクストラからのパッケージまたは私が欲しいものだけが含まれていますか?

ドキュメントによると、pacman(この場合はyaourt)は、呼び出されるたびにpacman.confを読み取ろうとします。それで、アップグレードしたくないセクションにコメントしようとしましたか?

2番目のポイントについて:

単一のパッケージを更新する方法は? yaourt -U <package>が機能しません(パッケージが見つからないか、読み取れませんでした)。 yaourt -S <package>を使用する必要がありますか?

Pacmanのインストールコマンド-Sは、実際には同期です。インストールまたはアップグレードは同じ方法で行われます。

$ pacman -S <package>

または:

$ yaourt -S <package>
5
César

Arch Linuxで1つのパッケージのみを更新するを実行する場合は、次のようにしますはコマンドを実行する必要があることを示していることに注意してくださいas root

1)パッケージの名前をで検索します

$ pacman -Sskeyword

(ここにパッケージの名前やその他のものが印刷されます)

2)次のコマンドを実行して、パッケージのURIを取得します

#pacman -Syup | greppackage's_name

(前のコマンドで取得したパッケージの名前を記述します。これで、パッケージのURIを取得する必要があります)

3)最後に、URIをコピーし、次のコマンドを実行して更新します

#pacman -Upackage's_uri

これが誰かに役立つことを願っています。ちなみに、これは推奨される方法ではありませんパッケージを更新します。可能であれば、システム全体をアップグレードしてください。ただし、これは、1つのパッケージを更新するだけで、システム全体のアップグレードを実行するための帯域幅がない場合に適した方法です(たとえば、最近、-だけを更新する必要がありました。 flashpluginパッケージ)

3