it-swarm-ja.com

Debian StableWheezyに最新のvirtualbox-dkmsと最新のvirtualboxをインストールする方法

以下を使用して、Wheezyに最新のvirtualboxと拡張パックをインストールすることができます。

# su sh -c 'echo "deb http://download.virtualbox.org/virtualbox/debian wheezy contrib" >> /etc/apt/sources.list
# wget -q http://download.virtualbox.org/virtualbox/debian/Oracle_vbox.asc -O- | su apt-key add -
# apt-get update
# apt-get install virtualbox-4.3

その後、virtualbox-dkmsをインストールしようとすると(カーネルのアップグレード後にvirtualboxが失敗するのを防ぐため)、virtualboxの最新(4.3)バージョンをアンインストールする必要があります。

4.3 virtualbox-dkmsは、wheezyバックポートでは使用できません。これは、管理者として/etc/apt/sources.listに次の行を含めて追加できます。

deb http://http.debian.net/debian wheezy-backports main

Wheezyの最新のvirtualboxとともに最新の4.3 virtualbox-dkmsをインストールするにはどうすればよいですか?

2
user75798

あなたはインストールする必要はありませんvirtualbox-dkms

doは、標準のDebianリポジトリの一部であるdkmsパッケージをインストールする必要があります。

私は通常、VirtualBoxをインストールする前にインストールしますが、順序は重要ではない場合があります。

$ Sudo aptitude install dkms
$ Sudo aptitude install virtualbox-4.3

カーネルの更新中に、DKMSがVirtualBoxモジュールを自動的に更新することがわかります。

https://www.virtualbox.org/wiki/Linux_Downloads

注:Ubuntu/Debianユーザーは、dkmsパッケージをインストールして、次のapt-getアップグレード中にLinuxカーネルのバージョンが変更された場合にVirtualBoxホストカーネルモジュール(vboxdrv、vboxnetflt、vboxnetadp)が適切に更新されるようにすることができます。 Debianの場合、LennyバックポートとSqueeze以降の通常のリポジトリで利用できます。

1
dezlov

別のパッケージになったので、OSEのバージョンによって異なります。 Ubuntu/DebianにPUELバージョン(最新バージョン)をインストールしようとするときは、次のファイルを追加するだけです。 6.0.2 @ /usr/src/vboxhost-6.0.2/dkms.conf:

PACKAGE_NAME="vboxhost"
PACKAGE_VERSION="6.0.2"
MAKE[0]="make"
CLEAN="make clean"
BUILT_MODULE_NAME[0]="vboxdrv"
BUILT_MODULE_NAME[1]="vboxnetadp"
BUILT_MODULE_NAME[2]="vboxnetflt"
BUILT_MODULE_NAME[3]="vboxpci"
DEST_MODULE_LOCATION[0]="/kernel/drivers/misc"
DEST_MODULE_LOCATION[1]="/kernel/drivers/misc"
DEST_MODULE_LOCATION[2]="/kernel/drivers/misc"
DEST_MODULE_LOCATION[3]="/kernel/drivers/misc"
AUTOINSTALL="yes"

dkms autoinstallを実行します。

1
snevas