it-swarm-ja.com

[email protected]インストール: `node-pre-gyp install --fallback-to-build` bcrypt 3.0.3

こんにちは私はこの問題を解決するためにすべてを試みました、何もうまくいきませんでした。 imがbcryptをインストールしようとすると、このメッセージが削除されます

[email protected] install: node-pre-gyp install --fallback-to-build

問題のログ(完全なログ https://github.com/kelektiv/node.bcrypt.js/issues/692 ):

1198 warn [email protected] No repository field. 
1199 verbose stack Error: [email protected] install: `node-pre-gyp install
--fallback-to-build` 
1199 verbose stack Exit status 1 1199 verbose stack     at EventEmitter.<anonymous> (C:\Program Files\nodejs\node_modules\npm\node_modules\npm-lifecycle\index.js:301:16) 1199 verbose stack     at EventEmitter.emit (events.js:182:13) 
1199 verbose stack     at ChildProcess.<anonymous> (C:\Program Files\nodejs\node_modules\npm\node_modules\npm-lifecycle\lib\spawn.js:55:14) 
1199 verbose stack     at ChildProcess.emit (events.js:182:13) 
1199 verbose stack     at maybeClose (internal/child_process.js:962:16) 
1199 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:251:5) 
1200 verbose pkgid [email protected] 
1201 verbose cwd C:\Users\user\Desktop\Programacion\Nodejs\node-rest-shop 
1202 verbose Windows_NT 10.0.17134 
1203 verbose argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "bcrypt" 
1204 verbose node v10.14.2 
1205 verbose npm  v6.4.1 1206 error code ELIFECYCLE 
1207 error errno 1 
1208 error [email protected] install: `node-pre-gyp install --fallback-to-build` 
1208 error Exit status 1 1209 error Failed at the [email protected] install script. 
1209 error This is probably not a problem with npm. There is likely additional logging output above. 1210 verbose exit [ 1, true ]

package.json:

"dependencies": { "bcryptjs": "^2.4.3", "body-parser": "^1.18.3", "express": "^4.16.4", "mongoose": "^5.4.0", "morgan": "^1.9.1", "multer": "^1.4.1", "request": "^2.88.0" },

バージョン:

npm:6.4.1

ノード:v10.14.2

3
Lucas

今日、Windows 10デスクトップにbcryptをインストールしようとしたときに、同じ問題に直面しました。 bcryptが安定したバージョンのノードをサポートしていることがわかります docs を確認してください

私のための解決策は:

  1. ノードを安定したバージョンにアップグレードします。Node WebサイトからWindowsインストーラーを手動でダウンロードしてインストールしました。
  2. Windowsビルドツールをグローバルにインストールします:npm install --global --production windows-build-tools
  3. 最後に npm install bcrypt --save

この後、すべてが正常に機能しました。

元の回答はこちら

1
stringnome