it-swarm-ja.com

vc_redist_2015 Setup Failed:0x80070666 Unspecified error

Windows 10 64ビットにvc2015(Microsoftからダウンロード)をインストールしようとしています

しかし、セットアップが失敗し、以下のエラーが表示されます

http://i.imgur.com/aZ0SAqV.png

ここにログファイルがあります:

[2468:0E28][2017-04-11T19:22:55]i001: Burn v3.7.3813.0, Windows v10.0 (Build 15063: Service Pack 0), path: C:\Users\Hamid\Downloads\vc_redist.x86.exe, cmdline: ''
[2468:0E28][2017-04-11T19:22:56]i000: Setting string variable 'WixBundleLog' to value 'C:\Users\Hamid\AppData\Local\Temp\dd_vcredist_x86_20170411192256.log'
[2468:0E28][2017-04-11T19:22:56]i000: Setting string variable 'WixBundleOriginalSource' to value 'C:\Users\Hamid\Downloads\vc_redist.x86.exe'
[2468:0E28][2017-04-11T19:22:56]i000: Setting string variable 'WixBundleOriginalSourceFolder' to value 'C:\Users\Hamid\Downloads\'
[2468:0E28][2017-04-11T19:22:56]i000: Setting string variable 'WixBundleName' to value 'Microsoft Visual C++ 2015 Redistributable (x86) - 14.0.24215'
[2468:0E28][2017-04-11T19:22:56]i100: Detect begin, 10 packages
[2468:0E28][2017-04-11T19:22:56]i000: Setting version variable 'windows_uCRT_DetectKey' to value '10.0.15063.0'
[2468:0E28][2017-04-11T19:22:56]i000: Setting numeric variable 'windows_uCRT_DetectKeyExists' to value 1
[2468:0E28][2017-04-11T19:22:56]i102: Detected related bundle: {c239cea1-d49e-4e16-8e87-8c055765f7ec}, type: Upgrade, scope: PerMachine, version: 14.10.25008.0, operation: Downgrade
[2468:0E28][2017-04-11T19:22:56]i108: Detected compatible package: vcRuntimeMinimum_x86, provider: Microsoft.VS.VC_RuntimeMinimumVSU_x86,v14, installed: {C6CDA568-CD91-3CA0-9EDE-DAD98A13D6E1}, version: 14.10.25008, chained: {BBF2AC74-720C-3CB3-8291-5E34039232FA}
[2468:0E28][2017-04-11T19:22:56]i103: Detected related package: {C6CDA568-CD91-3CA0-9EDE-DAD98A13D6E1}, scope: PerMachine, version: 14.10.25008.0, language: 0 operation: Downgrade
[2468:0E28][2017-04-11T19:22:56]i108: Detected compatible package: vcRuntimeAdditional_x86, provider: Microsoft.VS.VC_RuntimeAdditionalVSU_x86,v14, installed: {E6222D59-608C-3018-B86B-69BD241ACDE5}, version: 14.10.25008, chained: {69BCE4AC-9572-3271-A2FB-9423BDA36A43}
[2468:0E28][2017-04-11T19:22:56]i103: Detected related package: {E6222D59-608C-3018-B86B-69BD241ACDE5}, scope: PerMachine, version: 14.10.25008.0, language: 0 operation: Downgrade
[2468:0E28][2017-04-11T19:22:56]i052: Condition '(VersionNT = v6.3 AND NOT VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
[2468:0E28][2017-04-11T19:22:56]i052: Condition '(VersionNT = v6.3 AND VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
[2468:0E28][2017-04-11T19:22:56]i052: Condition '(VersionNT = v6.2 AND NOT VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
[2468:0E28][2017-04-11T19:22:56]i052: Condition '(VersionNT = v6.2 AND VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
[2468:0E28][2017-04-11T19:22:56]i052: Condition '(VersionNT = v6.1 AND NOT VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
[2468:0E28][2017-04-11T19:22:56]i052: Condition '(VersionNT = v6.1 AND VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
[2468:0E28][2017-04-11T19:22:56]i052: Condition '(VersionNT = v6.0 AND NOT VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
[2468:0E28][2017-04-11T19:22:56]i052: Condition '(VersionNT = v6.0 AND VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
[2468:0E28][2017-04-11T19:22:56]i101: Detected package: vcRuntimeMinimum_x86, state: Obsolete, cached: None
[2468:0E28][2017-04-11T19:22:56]i101: Detected package: vcRuntimeAdditional_x86, state: Obsolete, cached: None
[2468:0E28][2017-04-11T19:22:56]i101: Detected package: Windows81_x86, state: Absent, cached: None
[2468:0E28][2017-04-11T19:22:56]i101: Detected package: Windows81_x64, state: Absent, cached: None
[2468:0E28][2017-04-11T19:22:56]i101: Detected package: Windows8_x86, state: Absent, cached: None
[2468:0E28][2017-04-11T19:22:56]i101: Detected package: Windows8_x64, state: Absent, cached: None
[2468:0E28][2017-04-11T19:22:56]i101: Detected package: Windows7_MSU_x86, state: Absent, cached: None
[2468:0E28][2017-04-11T19:22:56]i101: Detected package: Windows7_MSU_x64, state: Absent, cached: None
[2468:0E28][2017-04-11T19:22:56]i101: Detected package: WindowsVista_MSU_x86, state: Absent, cached: None
[2468:0E28][2017-04-11T19:22:56]i101: Detected package: WindowsVista_MSU_x64, state: Absent, cached: None
[2468:0E28][2017-04-11T19:22:56]i052: Condition 'VersionNT >= v6.0 OR (VersionNT = v5.1 AND ServicePackLevel >= 2) OR (VersionNT = v5.2 AND ServicePackLevel >= 1)' evaluates to true.
[2468:0E28][2017-04-11T19:22:56]i199: Detect complete, result: 0x0
[2468:26B0][2017-04-11T19:22:59]e000: Error 0x80070666: Cannot install a product when a newer version is installed.

インストールされているプログラムのリストを確認しましたが、vc2015の兆候はありません

https://i.stack.imgur.com/T3QA2.png

3
hamidreza

Vc2017がインストールされているようです。 vc2017はvc2015へのバイナリ互換アップグレードです 。両方をインストールすることはできません。

Vc2015とvc2017の両方が同じメジャーバージョン番号14.xを共有していることがわかります。また、vc2017がvc2015と同じレジストリキーを使用していることも確認できるため、両方を並べてインストールすることは文字通り不可能です。

この動作は紛らわしいですが、バージョンのメジャー番号を見ると理にかなっています。

2
misha256