it-swarm-ja.com

DocumentDb.Emulatorのインストール

DocumentDb.Emulatorをエラーなしでインストールできます。ただし、起動しようとすると、次のエラーが発生します。

「api-ms-win-core-path-l1-1-0.dllが見つからないため、プログラムを開始できません」

Windows 7を実行しています。エミュレーターには新しいバージョンのWindowsが必要ですか? MicrosoftのWebサイトでシステム要件を確認できません。

3
Mike Thompson

From DocumentDB Emulatorシステム要件

DocumentDBエミュレータには、次のハードウェアおよびソフトウェア要件があります。

  • ソフトウェア要件
    • Windows Server 2012 R2、Windows Server 2016、またはWindows 10
  • 最小ハードウェア要件
    • 2 GB RAM
    • 10GBのハードディスク空き容量

したがって、おそらくいくつかの依存関係が欠落しています。


以前のバージョンのWindowsのサポート を要求するフィードバックページがあり、次のように述べています。

インストーラーは、サポートされていないプラットフォームでは実行しないでください。今、それは先に進んでインストールします、そしてそれからエミュレーターはapi-ms-win-core-path-l1-1-0.dllについてのあいまいなエラーで失敗します

そして返信

フィードバックをありがとう、私たちはそれを検討します。私たちのバックエンドコードは、Windows 7では利用できないいくつかの暗号化APIを使用しているため、現在サポートされていません。

5
Mokubai