it-swarm-ja.com

LinuxをWindows 8 Virtualbox経由で実行している場合、E_FAIL(0x80004005)

VirtualBoxをハイパーバイザーとして使用して、Winows 8.1マシンでLinuxを実行したいと思っていました。 Ubuntu(または別のインスタンスではFedora)を仮想マシンのリストに追加しようとした後、[スタート]をクリックしましたが、実行が拒否され、次のエラーが表示されました。

結果コード:E_FAIL(0x80004005)
コンポーネント:マシン
インターフェース:IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}

また、別のエラーメッセージも表示されました。

VirtualBoxの再起動中にエラーが発生しましたVMプロセス:5
コマンドライン: '81954AF5-4D2F-31EB-A142-B7AF187A1C41-suplib-2ndchild--comment Fedora32 --startvm fd699e30-a77b-4eac-8ced-1210d756855d --no-startvm-errormsgbox'(rc =- 104)

6
user135626

考えられる解決策:次のレジストリキーが問題を引き起こすようです:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers] "C:\ Program Files\Oracle\VirtualBox\VirtualBox.exe" = "DISABLEUSERCALLBACKEXCEPTION"

このエントリが存在するかどうかを確認してください。その場合は、それを削除して再試行してください。

アンチウイルスを無効にする必要がある場合もあります。何も機能しない場合は、次のいずれかを試してください。

  • アンチウイルスをアンインストールします(非推奨)
  • ウイルス対策ソフトウェアをMicrosoft Security Essentialsプレリリース(4.6)に置き換えます
  • VBoxをあきらめて、Hyper-Vを使用する

また、補足として、Windows 8.1 Pro以降を使用している場合は、MicrosoftのクライアントHyper-Vを試してください。私はVBoxよりもそれを非常に好みます。

3

VirtualBox 4.3.12へのダウングレードは機能しますが、4.3.16へのアップグレードは機能します。

今日、おそらくWindowsの更新とセキュリティ構成の変更の結果、user135626とまったく同じ問題が発生しました。

INSIDE VirtualBox 4.3.14から新しいバージョンを探すと、最新バージョンを実行していると言われました。これは間違っていました。

バージョン4.3.16は https://www.virtualbox.org/wiki/Downloads からダウンロードできます。

4
Otto Dandenell

これを見てください https://www.virtualbox.org/ticket/13187Virtualbox 4.3.14 crashes

これまでのソリューション(2014-8-17)は4.3.12にダウングレードするか、4.3.15テストケースを使用するようです。

3
Claudio Bastos