it-swarm-ja.com

Notepad ++ 7.4用XMLツールプラグイン

Notepad ++用のXMLツールプラグインを実行するのに苦労しています。

私は最新のNotepad ++(v7.4)と最新のXML Tools Plugin( Sourceforge からのv2.4.9.2)の両方を64ビット版のWindowsで持っています7(64ビット).

最初にNotepad ++のすべてのインスタンスを閉じました。それから、XMLTools.dllnotepad++.exeに記述されているようにinstall.txtと一緒に私のNotepad ++インストールのpluginsフォルダと依存関係(libs)にコピーしました。

Notepad ++を起動すると、次のようなエラーメッセージが表示されます。

%1は有効なWin32アプリケーションではありません。 XMLTools.dllは現在のバージョンのNotepad ++と互換性がありません

XML Tools PluginをNotepad ++ v7.4に "インストール"した後のエラーメッセージ:

Image]

1時間のグーグルでさまざまなバージョンのXMLツール、さらにはNotepad ++ v7.3.1を試してもそれ以上のことはわかりませんでした。誰かが私をこれで手伝ってくれる?

これが私のNotepad ++デバッグ情報です。

Notepad++ v7.4   (64-bit)
Build time : May 14 2017 - 21:02:35
Path : D:\Program Files\Notepad++\notepad++.exe
Admin mode : OFF
Local Conf mode : OFF
OS : Windows 7 (64-bit)
Plugins : mimeTools.dll NppConverter.dll 
10
Lilo

Windowsのインストールがどういうわけか壊れていたか、レジストリに問題があったかなど、私たちは決して知りません。

とにかく、私は新しいラップトップを持っていて、新鮮なWindowsがインストールされていて、すべてうまくいっています。

壊れたAPIやそのようなものはありません。

0
Lilo

次のようにして、2.4.9.2バージョンのXMLツールをWindows 10 64ビット版のNotepad ++バージョン7.4.1と連携させることができました。

64ビット版のツールを使用していることを確認してください。 (私の最初の間違い)

XMLTools.dllファイルをpluginsディレクトリにコピーします。

ダウンロードには、依存関係フォルダーがあるはずです。 (exeファイルがある)Notepad ++作業フォルダにそこにあるすべてのファイルをコピーします(私は6があったと思います)。

Notepad ++を再起動します。

2

Install.txtのインストール手順に従いましたか?

重要なのは、外部DLLもコピーすることです。

  1. nppメインフォルダ( "notepad ++。exe"と同じフォルダ)または%appdata%\ Notepad ++フォルダに新しい外部DLLをコピーします。
    • libcurl.dll
    • libiconv-2.dll
    • libwinpthread1-dll
    • libxml2-2.dll
    • libxslt-1.dll
    • zlib1.dll
2
FrankyHollywood

最初。正しいプラグインが必要です。 Notepad ++ 64-bitを使用するには、64-bit用のXMLツールをダウンロードする必要があります。簡単です。

第二。 Windows 10 64-bitのプラグインのメインフォルダは "C:\ Users {win_user}\AppData\Local\Notepad ++"にあります。

三番。 Notepad ++ 7.6以降のバージョンでは、プラグインに追加のサブフォルダが必要です。例: "{main_notepad_folder} /plugins/XMLTools/XMLTools.dll"と依存関係はメインフォルダーにあります。

2

XMLツールにはMicrosoft Visual C++再頒布可能ランタイム2015が必要です。 https://www.Microsoft.com/en-US/download/details.aspx?id=53840 をインストールしてください。

参照 SF.net Bugreport

更新

libcurl.dllがvc ++ 2015に同梱されているVCRUNTIME140.DLLを参照していることが、問題の原因であると考えられます。

内部バージョン番号

1
Bernhard

私はちょうど同じ問題を抱えています。このアプリケーションにとってはバグのようです。私は次のステップをやって解決しました:

  • Notepad ++バージョン7.3.3をインストールしてください。
  • XmlToolsプラグイン(現在はv2.4.9)をインストールしてください。

今、プラグインは正常に動作します。最も重要なことは、Notepad ++バージョンを最新のバージョン(現在はバージョン7.5.6)にアップロードできることです。プラグインはまだ正常に動作しています。

1
Iván

7.3.3 を使うとプラグインは動作します

enter image description here

そのため、APIの変更により、新しいバージョンではプラグインが破損しました。

変更に対応できるように、プラグインの開発者に報告してください。これを修正することはできません。そのため、新しいバージョンのプラグインが利用可能になるまで7.3.3に留まります。

0
magicandre1981