it-swarm-ja.com

古いバージョンのgfortranをWindowsにインストールする(cygwin x64)

Windows用にcygwin64ビットを使用しています。セットアップに必要なすべてのパッケージを提供しますが、古いバージョンのパッケージ(私の場合はgcc fortranコンパイラー)を入手する方法が見つかりません。バージョン4.9.2があり、バージョン4.4xが必要です。

1
James Wierzba

古いバージョンのパッケージを入手する方法が見つかりません

古いパッケージの完全なアーカイブはありません。

古いパッケージが本当に必要な場合は、Webで古いパッケージバージョン(gcc2-2.95.3-10-src.tar.bz2など)を検索することで、古いミラーまたはアーカイブミラーを見つけることができる場合がありますが、そのままにしておいてください。この古いバージョンはサポートされないことに注意してください。


Cygwinセットアップを使用して古いバージョンのパッケージ(gcc-2.95など)を取得できますか?

Cygwin Setupを使用して、Cygwinミラー上にあるパッケージをインストールできます。これには通常、現在のバージョンより1つ前のバージョンが含まれています。

完全なリストは https://cygwin.com/packages/ で検索できます。

古いパッケージの完全なアーカイブはありません。 Cygwinパッケージの現在のバージョンに問題がある場合は、 https://cygwin.com/problems.html のガイドラインを使用してメーリングリストに報告してください。

とはいえ、本当に古いパッケージが必要な場合は、Webで古いパッケージバージョン(gcc2-2.95.3-10-src.tar.bz2など)を検索することで、古いミラーまたはアーカイブミラーを見つけることができる場合があります。ただし、この古いバージョンはメーリングリストでサポートされておらず、古いバージョンをインストールしてもCygwinの改善には役立たないことに注意してください。

ソース Cygwin FAQ

2
DavidPostill