it-swarm-ja.com

Eclipseをポータブルにする

注:はい、私は見ました thisしかし、Eclipseは2010年以降、何かを変更したようです。フラッシュドライブから新規インストールを実行しても機能しなくなりました。 2010年に質問と回答があったので、誰もがわざわざ更新するつもりはないと思うので、新しい質問をします。

Eclipseをフラッシュドライブに移植可能にインストールしたい。私はいつもやってきたことをやってみました-インストーラーにフラッシュドライブにインストールするように言ってください-しかし今、それは私にその共有コンパニオンライブラリを見つけることができないというエラーを与えています。具体的には、次のエラーが発生します。

A popup with the title "Eclipse" and body text "The Eclipse executable launcher was unable to locate its companion shared library." There is a button to the bottom left that says "OK", and a red X button in the top right. There's nothing but that.

コマンドラインから実行すると同じ結果が得られ、コマンドラインに余分なものは何も出力されません。

これは完全に新しいインストールであり、 ダウンロードページ に移動し、[ダウンロード]をクリックして実行可能ファイルを実行し、最初のオプションである「Eclipse IDE = for Java Developers "]次に、パスを変更してフラッシュドライブに配置します。

インストールしたコンピューターで起動すると正常に動作します。ただし、そのような場合、ほとんどの場合、フラッシュドライブに何かをインストールするという目的は無効になります。

それがうまくいかなかったので(明らかに)私は何が欠けていますか? Eclipseをポータブルにするにはどうすればよいですか?

私の現在のコンピューターはWindows8 64ビットですが、Windows 7 +、32、および64ビットで動作させたいです。技術的には、現時点で実際に必要なのはWindows 732ビットとWindows8 64ビットだけですが、忘れられるように、もっと広く使えるようにしたいと思います。

フラッシュドライブには、いくつかのインストールに十分なスペースがありますが、1つだけにしたいのですが、modを管理できる十分なプログラミング経験がありますが、ソフトウェアを更新しても解決策は残ります。


Zipファイルを使用しました。さて、最初は動作しているように見えますが、その後、異なるコンピューターで異なるワークスペースを開きます。最善の努力にもかかわらず、EclipseにJREとJDKの相対パスを使用させることができません。つまり、ドライブが割り当てられている場合にのみ正しく動作します。正しい文字。要するに、まだポータブルではありません。

「portableapps.com」形式を使用して、EclipseNeonのポータブルバージョンと最新のOxygenビルドを作成しました。ここからダウンロードできます: https://sourceforge.net/projects/Eclipse-neon-portable/

この説明も参照してください: http://portableapps.com/development

1
Berny23