it-swarm-ja.com

Microsoft .NET Frameworkのすべてのバージョンが必要ですか?

4つのMicrosoft .NET Frameworkバージョンがあります。

  • 1.1
  • 2.0 Service Pack 2
  • 3.0 Service Pack 2
  • 3.5 SP1

それらすべてが必要ですか?

23
Joy Seacat

.netフレームワークには4つのdistinctバージョンがあります。

  • .NET 1
  • .NET 1.1
  • .NET 2
  • .NET 4

これらはすべて個別にインストールおよびアンインストールできます。ここが面白くなるところです! .NET 3が(.NET 2のサービスパックと共に)導入され、それに追加されたライブラリセットでした。 .NET 3.5はこの傾向に従い(.NET 2の2番目のサービスパックと.NET 3のサービスパックで)、. NET 2を拡張しただけで、再び.NET 2を必要としました。

最新のリリースは完全にスタンドアロンであり、以前のバージョンを必要としません。ほとんどの場合下位互換性があるため、古いアプリケーションで動作させることが可能です。

それらのいずれかが必要かどうかは、実行しているものによって異なります。そこにあるほとんどのアプリケーションは.NET 2から3.5に対応するように構築されているため、3.5をインストールすればそれをカバーできます。マイクロソフトが人々に使用してほしいと期待しているので、4をインストールすることをお勧めします。

.NET 4.5(および4.5.1、4.5.2)は、.NET 4のインプレースアップデートです。

12

.Net Framework 3.5のインストールでは、2.0以降のすべての以前のバージョンもインストールされます。バージョン1.1は例外であり、個別にインストールする必要があります。

3.5 SP1バージョンが必要と思われるため、これにより、2.0以降のすべての.Netバージョンもインストールされます。そのため、本当にそれについて選択の余地はありません。あるバージョンをアンインストールしようとすると、その上に構築されている他のバージョンで問題が発生する可能性があります。

.Net 1.1を必要とする製品がほとんど残っていないため、本当に必要になるまで、インストールを待つことができます。自動的にインストールされないため、すでにインストールされている場合は、インストール済みの製品で必要になります(デフォルトでインストールされているXPを使用している場合を除く)。

.Net 4.0については言及していませんが、このバージョンでは、以前のバージョンをすべて含めないようにして、ソフトウェアのサイズを小さくしようとしました。したがって、.Net 4.0はサイズが小さく、1.1以降のすべての以前のバージョンとの下位互換性があると思われます。したがって、理論的には、それだけが必要です。

7
harrymc

異なるアプリケーションには異なるフレームワークが必要であり、下位互換性はないので、すぐにダウンロードする必要はありませんが、すべて必要な場合があります。
特定のバージョンのフレームワークを必要とするアプリケーションをインストールするときに、それらをダウンロードできます。 (ほとんどの場合、2、3、または3.5が必要になります)

6
Shekhar

Net4が必要なすべてであることについては当てはまりません。すべてのバージョンを削除してから、v4のみをインストールしました。最初に実行しようとしたアプリ(Powermate)は、必要な.NET Frameworkが見つからなかったと言っています。そこで、Net v2 SP2とSP2アップデートをインストールしましたが、アプリは問題なく実行されました。

2
Ken Roberts