it-swarm-ja.com

3.xカーネル上のAsusPCE-N53 11n N600PCI-Eアダプター

問題

ASUSPCE-N53ワイヤレスNIC最新バージョンのLinuxカーネルでは機能しません。システムで機能させるにはどうすればよいですか?

3
CITguy

Linux3.xカーネル用のドライバーのインストール

ASUSはウェブサイトからLinuxドライバーを提供していますが、ドライバーは「Linux Kernel 2.6.x」をサポートしていると記載されているため、ドライバーコードにいくつかの変更を加えると機能しません。

幸いなことに、 archlinuxフォーラム は同様の問題に言及しており、1人のユーザーがカーネル3.11.xで動作するように見えるカーネル3.8.xのパッチを作成することができました。

これが私がそれを機能させた方法です:

前提条件

Ubuntu:

Sudo apt-get install build-essential

アーチ:

Sudo pacman -S base-devel linux-headers

手順:

1. ASUSウェブサイト からドライバーをダウンロードします

ダウンロードは「サポート>ドライバーとツール」の下にあります。

2.ダウンロードしたファイルの内容を解凍します

新しいディレクトリにcdします

3.パッチ

Archフォーラムでは、ダウンロードする必要のある3.8パッチファイルについて言及しています。

  1. ダウンロードrt5592sta_fix_64bit_3.8.patch現在のディレクトリに移動します。
  2. tar -xvf {driver_source.tar.gz}
  3. cd前の手順で作成したディレクトリに
  4. patch -p1 < ../rt5592sta_fix_64bit_3.8.patch

4.コンパイル

[〜#〜] note [〜#〜]:正しくコンパイルするには、Sudoを使用する必要があります。

Sudo make
Sudo make install
Sudo modprobe rt5592sta

5.お楽しみください

すべてが順調であれば、作業カードができているはずです。

3
CITguy