it-swarm-ja.com

CentOS 6.4でのPHP 5.3.3から5.4.4へのアップグレード

CentOS 6.4(centos-release-6-4.el6.centos.10.x86_64)を使用しています。次のコマンドを使用して、phpのバージョンを5.3.3から5.4.4にアップグレードしようとしています。

yum upgrade php-mysql php-devel php-Gd php-pecl-memcache php-pspell php-snmp php-xmlrpc php-xml

そして

yum upgrade php

...しかし、これは私が受け取っている唯一のメッセージです:

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.netnitco.net
 * extras: mirror.wiredtree.com
 * updates: mirror.thelinuxfix.com
Setting up Update Process
No Packages marked for Update

私はすでに走りました:

yum update

そしてすべてが整然としている。 php-*での/etc/yum.confの除外も確認しましたが、何も見つかりませんでした。何か案は?ありがとう!

更新:ソリューション

@ mirkobrankovic のおかげで(64ビットOSで)これをやめました:

wget http://download.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
rpm -ivh epel-release-6-8.noarch.rpm
wget http://rpms.famillecollet.com/enterprise/remi-release-6.rpm
rpm -Uvh remi-release-6*.rpm
yum --enablerepo=remi upgrade php-mysql php-devel php-Gd php-pecl-memcache php-pspell php-snmp php-xmlrpc php-xml
9
Andres SK

多分これ question があなたを助けることができます。
レミリポジトリを使用してください。CentOSベースから取得することはできません。
追加方法 remi repo

5
mirkobrankovic

PHP 5.3.3から5.4.4に更新するには:

wget http://download.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
rpm -ivh epel-release-6-8.noarch.rpm
wget http://rpms.famillecollet.com/enterprise/remi-release-6.rpm
rpm -Uvh remi-release-6*.rpm
yum --enablerepo=remi upgrade php-mysql php-devel php-Gd php-pecl-memcache php-pspell php-snmp php-xmlrpc php-xml
9
luis-venezl