it-swarm-ja.com

yumインストールエラー:保護されたmultilibバージョンエラー

Opensslの開発ヘッダーをRHEL6.1システムにインストールしようとしていますが、次のエラーが発生します。

$Sudo yum install  openssl-devel.x86_64


<SNIP>
--> Finished Dependency Resolution
Error: Protected multilib versions: openssl-1.0.0-10.el6.i686 != openssl-1.0.0-10.el6_1.4.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

誰かがこれに遭遇したことがありますか?

1
Setjmp

私は実行しました

Sudo yum downgrade openssl
Sudo yum install openssl-devel.

そして今、物事はうまくいくようです。

3
Setjmp

ちなみに、これはアーキテクチャ間にバージョンスキューがあることを意味します(複数のアーキテクチャに共通するファイル間に衝突があります。これはバグとして報告する必要があります。

0
vonbrand